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CHAPTER 1 INTRODUCTION 

1. INTRODUCTION 
The aim of this tutorial is to gain familiarity with the main applications provided with the Base 
Module of WindFarmer.  It can be run using either the Demonstration version or the fully 
activated version of the software.   The main functions in the Base Module are: 

• Assessment of wind farm energy production 

• Layout optimisation considering technical and some environmental constraints 

• Management of multiple projects 

• Noise modelling 

• Graphing 

This tutorial concentrates on building workbooks for energy calculations and layout optimisation 
in simple wind farms, with and without the use of the WindFarmer Wizard.   Further tutorials 
cover other functions in this module and others.   

The family of tutorials are supplements to the User Manual and the Theory Manual of 
WindFarmer.  The user should refer to these for more information.  They can be accessed from 
the dropdown menu for WindFarmer found in the Start, Programs list of your computer.  With 
WindFarmer software open, you can also access the Help files through the Help menu item.  

The exercises use sample files provided in a folder called ‘Demodata’, which can be found in 
Libraries\Documents\WindFarmer.  Users of Windows XP can find this folder inside the 
WindFarmer installation directory, which is usually C:\Program Files\WindFarmer. 

Throughout the tutorials, we recommend you save your work from time to time.  However, note 
that Workbooks cannot be saved from the WindFarmer demonstration version.   
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BEFORE USING WINDFARMER 

Documents 

The same documents are included in the Full and Demo versions, and are accessed 
via Start, All Programs, WindFarmer dropdown.   They currently comprise: 

– Tutorials:  Base Module, Visualisation, WAsP and Other 
Modules  
 

– Manuals:  User Manual (in chosen language), Theory 
Manual, Validation Report, Help files 
 

– User Manual Supplement:  Details of features in this latest 
version.   
 

– Launch and uninstall 
 

File extensions 

When working with WindFarmer we recommend that you reveal all the file extensions 
in order to distinguish between demo files having the same name.  

 

- In Windows Explorer, display 
the menus by selecting 
Organize, Layout, Menu bar 
 

- Use View menu to select 
“Details” view   
 

- In Tools menu, Folder 
Options, untick “Hide 
extensions for known file 
types” and press “Apply to all 
folders”.   

     

To check version and activation 

- In the WindFarmer interface, go to Help, 
About WindFarmer to see the version 
number 
 

- “Advanced” button reveals which modules 
are activated.   In the Full version you see 
“Yes” or “No” in the “Enabled” column.  
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2. BUILDING A WORKBOOK FOR A 
SIMPLE WIND FARM ENERGY 
ASSESSMENT USING THE WIZARD  

In this exercise you will learn: 

• how to create a new workbook using the WindFarmer Wizard 

• how to read and load new information in the Project Properties 

• how to run an energy test using the advanced Eddy Viscosity model 

The steps that follow can be carried out using the Demo version of the software with the demo 
data provided, or with your own data using the fully activated version.  

2.1 Creating a new workbook using the Wizard 
Step 1.  Start WindFarmer using the shortcut icon on your desktop or from the Start Menu 

> Programs > WindFarmer >  WindFarmer.   

When you open WindFarmer or create a new Workbook, the Wizard “Welcome” panel and an 
empty Mapping window will appear.  If you have deselected this option go to File > Workbook 
Wizard to start the Wizard.  The window below appears: 
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Step 2. Click “Next” from the “Welcome” window of WindFarmer Wizard 

Four options are then available to define the working area.   Only one is required.  For this 
exercise, you will load a terrain contour file (MAP file) and a background map image (BMP file).  
Note that for energy calculations these two files are just used as background and not as input 
for calculations. 

Step 3. Click browse for the MAP file, and load “Demo.map”, located in the Demodata 
folder of the WindFarmer library.   

 

Step 4. Click browse for the BMP file and load “DemoColourRefmap.bmp” from the 
Demodata > Refmaps folder. 
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Step 5.  Click NEXT.  The dialog box below will appear. 

 

Note: You can move the Wizard panel to one side of your screen to see better the data you 
have just loaded.  

You will now load the wind resource data, previously created in your flow model (usually WAsP).   
Wind resource files can either be WRG files or RSF files, as described in the tutorial on the use 
of WAsP for WindFarmer.  In this example, you will use a WRG file.  In simple terms, this is a 
wind map where the wind statistics at each point of the grid are represented by the estimated 
Weibull parameters for each direction of the frequency distribution. 

WindFarmer includes a flow model as one of its features, and can also control WAsP directly.  
How to do this is explained in the later exercises. 

Step 6.  Click “Browse” and load the file named “Demo.wrg”.  It will take a few seconds to 
load. 

Step 7. WindFarmer will ask if you want to load a frequency table.   

 

Click “YES” and load the file “Demo.tab”.   This is the data measured at the 
anemometry mast.   

Step 8.  A message will appear prompting you to load single point WRG file:  
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Click OK and load the file named “Demomast_MastHeight.wrg”.  Steps 7 and 8 
allow WindFarmer to use the wind frequency distribution measured at the mast 
and factor it to the single point Wind Resource Grid loaded in step 8.  Note: The 
scaled measured distribution often is a better approximation of the frequency 
distribution of the site than the derived Weibull parameters.  For more information 
on this process, refer to the WindFarmer Association Method in the User’s Manual. 

Step 9.  A message warns that the default turbulence intensity at mast height is set to be 
10%. Click OK.  Changes to the default value can be carried out later. 

 

Step 10.  Click NEXT three times until you reach the window named “Workbook Wizard – 
Optimisation and Testing” (see window below).  In this window click “Finish”.    

 

At this point you see the background map, a rectangle (the Demo.wrg, the wind 
map) and the mast location identified with  within the rectangle. 

Step 11.  If you are using the full version of WindFarmer, save the workbook using File > 
Save Workbook As and give it a name.  The file will have the extension *.WOW  
 
Note:  you will not be able to save the workbook if you are running a WindFarmer 
demonstration version. 
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2.2 Creating a wind farm layout 
Step 12. Turn on the Mapping Toolbar by selecting View menu > Toolbars… > Mapping. 

Step 13. Activate the Turbine Mode by clicking the Turbine Mode button  on the 
Mapping Toolbar or by selecting Modes menu > Turbine.  The cursor changes to 
indicate the program is in Turbine mode.  Note: If you double-left click anywhere on 
the screen the mode will change back into the Working Mode, indicated by a white 
arrow. 

Step 14. Insert the wind turbines within the rectangle with the right click of your mouse.  In 
this specific exercise you are going to insert 5 turbines.  

Note: you can delete a turbine by left clicking on the turbine ID in the “Control bar-
Information tab” and pressing “Delete” on the keyboard, or highlighting a turbine by 
left clicking on it in the turbine mode and pressing “Delete”.  Alternatively you can 
delete a cluster of turbines by draping a rectangle while keeping the left mouse 
pressed.  

In the following image, the site mast is near Turbine 1. 

 

Note that the Wizard has automatically created a boundary with the same size as the Demo.wrg 
file. Boundaries are required because turbines can only be added within a boundary.  The use 
of the boundaries will be clearer in the optimisation exercises. Turbine positions are editable.  In 
the next exercises, different ways to edit turbine locations will be explained.  

Note that by unticking “Background” in Map Data on the left of the screen, you can hide the 
background image and view only the turbines, the mast and the MAP file, as shown below. 
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2.3  Settings in Project Properties and Turbine Studio 

Step 15.  Click  on the Main Toolbar or go to View menu > Project Manager. 

Step 16.  Right click on “Project Name”.  Rename the project.  For this specific case, rename 
this project “Demo01” as shown in the figure below.   

 

Step 17. Click “OK” to close the Project Manager. 

Step 18.  Click  on the main toolbar or go to View > Project Properties on the toolbar.  
Multiple pages are contained within the “Project Properties” window.  

 
About the “Project Properties” window: 

A “Project” in WindFarmer is normally a single wind farm.  The parameters for each project 
need to be set before continuing further with the analysis.   For this exercise, the default 
values can be used, but we will set a few values for demonstration purposes. 

• “Wind Resource Grid Priority” page shows that a Wind Resource Grid (the windmap) 
named Demo.wrg is loaded, having resolution of 50 m and wind data predicted at height 
of 46 m.  

• “Wind resources and frequency table association” page shows that the Demo.wrg (the 
wind map produced at 46 m) is associated to Demo.tab (the measured wind frequency 
distribution at the mast at 27 m).   

• “Energy” page contains input for the reference air density.  Enter either a site reference 
air density plus the altitude of the measurement, or input the air density at a nearby 
meteorological station.  For this exercise switch to “Met station air density” and press 
“Apply” to store this variation. 

• “Energy Efficiencies” page provides inputs for all the typical losses from a wind farm in 
terms of efficiency. Some of these figures can be calculated by WindFarmer or 
assigned by the user.  For example, enter Availability = 97%, Icing and blade 
degradation = 99%, Substation maintenance = 99.8%, Electrical efficiency = 97%.  
Press “Apply” to store these changes. 

•  “Turbulence Intensity” page is the input required for use in the Eddy Viscosity wake 
model.  If the turbulence module is not activated, the only two options are to set a 
“global value of turbulence intensity” or to derive the turbulence from the site roughness 
set in the Energy panel of the Project Properties. In this exercise set a global turbulence 
intensity of 12% and press “Apply” to store this variation.  When the WRG is associated 
to a TAB file (as in  Step 7), the turbulence intensity should be that at the mast.   

• Click OK to close the window and save the changes for use in the subsequent energy 
calculations.  
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Step 19.  Open Turbine Studio by clicking  on the main toolbar or go to View menu > 
Turbine Studio.  A window appears for entering the required turbine properties.  It 
contains the default specifications for a “Generic Turbine” which will be used in this 
exercise.   The values in the table are editable.  

 

Step 20.  Close the window by clicking “OK”.   

About the “Turbine Studio” window: 

The Turbine Studio is where you define the specifications of the turbines you are working 
with.  You can load turbines from the library which is supplied with WindFarmer, or you can 
define new types. 

Several models of turbine can be loaded into the Turbine Studio at the same time.  A great 
range of technical characteristics are defined here, including rotor diameter, hub height, and 
power and noise curves. The 3D appearance of the turbine can also be set here.   

When you are defining new models of turbines, Turbine Studio will let you record references 
to the original documents in which you found the specification, so that you can keep track of 
your work.   

2.4 Settings in Control Panel 
Before running an energy calculation, settings also need to be confirmed in the Control Panel.  

Step 21.  Click  on the main toolbar or go to View > WF Control Panel.  Multiple pages 
are contained within the Control Panel.  
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Step 22.  Click on to the “Energy” page, and select “Eddy Viscosity” as the wake model to be 
used in the calculation.  Press “Apply” to store these changes.  Note that the 
Modified Park is set as default and is generally recommended for quick 
calculations and when working with the optimiser. 

Step 23.  Click on the “Optimiser” tab to check the constraints are as required, such as 
maximum ground slope and minimum turbine spacing.   For this exercise, leave 
the settings on this page unchanged.   Press “Apply” to store any changes and 
then OK.    

2.5 Running the energy calculation 

Step 24.  Click the Test button  on the mapping bar or go to Calculate > Energy/Test.  
WindFarmer then tests that the layout is valid with respect to any constraints.  If no 
constraints are exceeded, then the energy calculation is carried out.  This will take 
a few seconds. 

2.6 Saving the results 
Step 25.  A spreadsheet called “Report” will automatically appear.  Click the button 

“Generate Report” at the bottom left corner of this window.  Note if you are running 
a WindFarmer demonstration version, you will obtain a report with reduced 
content. 

A window called “Report Generator” appears.  Many options for exporting input or 
output data and customising the report are available and we recommend exploring 
all these options later.   

Step 26. For the purpose of this exercise click on “Generate Energy & Turbine Results 
Report” near the bottom left corner.  This exports the same information as in the 
automatic spreadsheet just viewed.  

Step 27.  The report can be saved as DOC, XLS or TXT format.  For this exercise, assign 
the name “Demo01.doc” and save the report with DOC extension. Reporter will 
take a few seconds to generate the report, save it and display it on the screen. 

Step 28.  Scroll the document to familiarise yourself with the input and output data produced 
in the report. Some parts of this document are empty since you have not 
introduced any related input in our process. The demo version of the software also 
has some limitations on the information that can be produced, especially the 
details at each individual turbine. 

Step 29. Close the report document.  Back in the WindFarmer display, notice that the 
Information panel on the right hand side of the screen also summarises the energy 
yields overall and for each turbine.   

   End of the exercise 
 

WINDFARMER TUTORIAL FOR BASE MODULE 10 



CHAPTER 3 WIND FARM ENERGY ASSESSMENT 

3. BUILDING A WORKBOOK FOR MORE 
COMPLEX WIND FARM ASSESSMENT, 
WITHOUT THE WIZARD  
In this exercise you will learn: 

• how to create a new workbook for energy analysis, without using the Wizard 

• how to insert and edit boundaries, turbines and other objects 

• how to input the wind climate at the site 

• how to use a flow model to calculate the changes in wind speed around the site 

• how to input the required information in Project Properties, Turbine Studio and 
Control Panel to run an energy calculation 

The procedure that follows expands on the steps covered in the previous exercise and can 
be carried out using the demo data.   

This exercise is useful for learning how to handle a project with multiple site masts or WRGs 
for several hub heights.  However, though the method will be thoroughly explained, the 
demo data provided with WindFarmer does not enable the user to handle a scenario with 
multiple masts. 

The exercise describes how to build a Workbook without using the Wizard.  This is also 
useful if you do not require any wind data to be included, for example for simple noise 
analyses.   

3.1 Creating a new Workbook  
Step 1.  Start WindFarmer using the shortcut on your desktop or from the Start Menu > 

Programs > WindFarmer >  WindFarmer.  If WindFarmer is already open, click 

the New Workbook icon  or select File menu > New Workbook. 

When you open WindFarmer or create a new Workbook, the Wizard “Welcome” panel will 
appear with an empty Workbook.   If the Wizard has been de-activated, it can be re-activated 
from File menu > Workbook Wizard.  

Step 2. Click “Cancel” to close the WindFarmer Wizard and have an empty workbook.  
Maximise the Mapping Window if it does not cover the whole area. 

Step 3. Click the Load File button  , or select File menu > Load File… 

Step 4. Load “Demo.map”, located in the Demodata directory of the WindFarmer library. 
The contour map will appear in the Mapping Window and the “Terrain” check box 
of the Display Bar - Map Data will be ticked. 

Step 5. From the “Map” menu, select “MAP2DTM”.  Click “OK” to the default resolution of 
50m.  This converts the contour map into a digital terrain map (DTM) – a grid of 
elevation data. 
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The contour and DTM maps will be used by WindFarmer to calculate how the wind flows 
across the site.  How to produce a *.MAP format contour map is described in the Tutorial for 
WAsP. 

Step 6. Hide the DTM from display by unticking “DTM” in the Map Data panel on the left of 
the screen. 

3.2  Creating boundaries 
Before placing turbines on the map, it is necessary to define the site boundary.  Turbines 
cannot be placed in WindFarmer unless their location is within a valid boundary area.  

Step 7.  To create a boundary, click the New Boundary button  in the Mapping Toolbar 
or select Add > New Boundary from the menus.  

Step 8.  In the workspace, use the right click of your mouse to insert the points of your 
boundary. A background image can be helpful.   Left clicking the mouse inside the 
area completes the boundary.    

Note:  Boundary points can be deleted by left clicking the node in the boundary mode and 
pressing ”Delete” on your keyboard.  The entire boundary can be deleted by right click at a 
node of the boundary while in working mode and selecting “Boundary properties” from the 
list.  In the window that appears, select the “Delete entire boundary” option.  

Step 9.  Create a second boundary, separate from the first one.  To do this, again click 

 on the Mapping Toolbar or click Add > New Boundary from the taskbar.   
Right click to add the boundary points.   Left click to complete the boundary. 

The red lines in the figure below show how the boundaries might look.  Note that boundaries are 
always closed; no open boundaries are allowed.  

  

Step 10.  To edit an existing boundary, you need to be in Boundary Mode.  If necessary, 

click the Boundary Mode button .   Points can then be moved, deleted or 
added to the boundary.   

The properties of a boundary can be viewed and edited in the Boundary Properties window, 
accessed using a spot menu.  To use the spot menu option, first you must be in Working 
Mode. 

WINDFARMER TUTORIAL FOR BASE MODULE 12 



CHAPTER 3 WIND FARM ENERGY ASSESSMENT 

Step 11. To switch to “Working Mode”, click on the arrow button  on the Mapping 
Toolbar, or double-left click on the background map.  When in Working Mode, your 
cursor is a white arrow.  

Step 12. Then right click on any boundary point until the option window appears.   This lists 
the information available at that spot.   

 

Step 13.  Select “Boundary properties”. The window below will appear: 
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Some useful information about the “Boundary Properties” window: 

• “Boundary point” section indicates the node number and its coordinates.  Click  
up or down to switch between nodes. The coordinates are editable. 

• “Boundary point is part of boundary” section shows the boundary number, with arrows 
to switch from boundary to boundary.  Each boundary can optionally be labelled.  In this 
specific example there are 2 boundaries (created in the last steps). 

• “Lock boundary” box is unticked by default. When ticked, turbines cannot be added, 
deleted or moved in the boundary or to other boundaries.  For turbines to move during 
optimisation, the boundaries need to be unlocked.  See tutorials about optimisation for 
more details. 

• “Show boundary”: if the box is unticked, the boundary lines are hidden and only the 
points remain visible. 

• “Choose fill pattern” provides options to fill the boundary area with hatching or colour, 
either transparent or opaque. 

• “Delete entire boundary” removes the boundary irreversibly. 

• “Boundary interaction with turbines – type of interaction” provides three options. As 
default it “contains XX turbines” (currently the cell reports 0 because there are no 
turbines).  Changing the number will make WindFarmer insert new turbines according to 
the “Boundary Fill” settings.  The “exclude turbines” option disallows turbines within the 
boundary and “does not affect turbines” is used if you want the boundary to be just a 
reference on the map with no interaction with the turbines. 

• “Boundary interaction with turbines - Minimum distance from boundary” allows distance 
criteria to be set for the distance of the turbines from the boundary, either as a given 
distance in metres or related to the turbine geometry.  These criteria are used in 
optimisation.   

• “Boundary Fill” provides tools for placing a number of turbines inside the boundary.  
“Packed Fill” places turbines closely together.  “Manual Symmetric Fill” places turbines 
in a regular grid structure.  The “Contains XX turbines” field determines how many 
turbines will be placed within the boundary.  See the User Manual for details. 

 

Step 14. Press “Choose fill pattern” in the “Boundary properties” window. 

Step 15.  Several options are displayed. For the exercise choose a “brush”. Click OK to 
return to the “boundary properties” page. 

Step 16.  Still in the “Boundary properties” window go to “Boundary point is part of boundary” 
and switch to boundary number 2. 
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Step 17.  Press “Choose fill pattern” and, for this exercise, associate a pattern different from 
before.  The pattern will not affect any calculation in WindFarmer and is simply a 
feature to improve the view on screen. Click “OK’ to close the Boundary Properties 
window.  

 

3.3  Inserting turbines 

Step 18.  Activate the Turbine Mode by clicking the button  on the Mapping Toolbar or 
through the main toolbar by selecting Modes menu > Turbine. 

Step 19.  Insert wind turbines within the two boundaries using right mouse click. In this 
specific exercise insert Turbines 1, 2, 3 and 4 in Boundary 1 and Turbines 5 and 6 
in Boundary 2.  

 

Note that to delete a turbine, click the turbine ID in the “Control Bar-Information tab” and 
press “Delete” on the keyboard, or highlight the turbine by left clicking on it when in Turbine 
Mode and pressing “Delete”.  To move a turbine, left click on it when in Turbine Mode and 
drag it around whilst keeping the left mouse button pressed. 
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About deleting objects and assigning common properties 

• Objects inserted in a Mode (such as turbines, dwellings, viewpoints, anemometry 
masts, radar stations, etc.) can generally be deleted in the “Control bar - Information 
tab” by left clicking under ID and pressing “Delete” on  the key board or left click at the 
object while being in the appropriate mode and pressing “Delete”. 

• Some objects (i.e. turbines, viewpoints, dwellings, etc.) can also be deleted as a cluster 
of objects by draping a rectangle in the appropriate mode while keeping the left mouse 
pressed. A dialog box appears asking to either associate common properties to all the 
same objects included in the rectangle or delete them. 

• To go back to the “Working Mode” press  on the mapping bar or alternatively with a 
double left click on the workspace where there are no objects. 

• If there are objects that have previously been inserted it is possible to switch to that 
specific Mode by double left clicking on one of these existing objects.  

 

3.4 Settings in Project Properties and Turbine Studio 
Before we move on to running an energy calculation, the correct information must be entered in 
Project Properties and Turbine Studio.  

Step 20.  Click  on the Main Toolbar or select View menu > Project Manager. 

Step 21.  Right click on “Project Name”.  Rename the project as “Demo02”.  Press OK to 
close the window. 

Step 22.  Click the Project Properties button  on the Main Toolbar or select View menu 
> Project Properties.  

Step 23.  Select “Energy” page to set up a reference air density.  

You can either input a site reference air density, plus altitude of the measurement; 

Or, for this exercise, switch to “Met station air density”  

Press “Apply” to store this variation.  

Note that in this page “Apply direction shift to sector probability” allows you to select whether 
or not to use the wind rose shift predicted by the wind flow model;     

Step 24. Select “Energy Efficiencies” page.  In this window all the typical losses from a wind 
farm can be taken into account in terms of efficiency.  Some of these figures can 
be calculated by WindFarmer; others are assigned by the user.   

In this exercise set: Availability = 97%, Icing and blade degradation = 99.5%, 
Substation maintenance = 99.8%,  Electrical efficiency = 98%.  Press “Apply” to 
store these changes.  

Step 25.  Click OK to close the Project Properties window.  From now on all the settings you 
have implemented in the “Project Properties” will be used in the energy calculation. 

Now use the Turbine Studio to enter the correct turbine parameters for the analysis. 
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Step 26.  Click the Turbine Studio button  on the Main Toolbar or go to View > Turbine 
Studio.  A window with the relevant turbine specifications appears with default 
specifications for a “Generic Turbine” with 46 m hub height, the same height as the 
“Demo.wrg” file. 

 
 

Explore the “Turbine Studio” window:  

• Turbine Studio enables you to build, and access, a library of different turbine types.  For 
each turbine type loaded into the studio, there are pages for:  Power Curve, Noise and 
Turbine IEC Classification.  It is also possible to define the 3D appearance of a turbine. 

• A library of turbine definitions is provided with WindFarmer.  It covers a range of 
turbines from major manufacturers, and in many cases includes power curve data for 
several air densities.   

• When opening “Turbine Studio” in a new Workbook, only details of a default “Generic 
turbine” are present.  For work on your own wind farm, we advise inserting the 
parameters of your own turbine model, in a new model, and then removing the generic 
turbine using the “Unload” button .  After building the library of turbine types, they can 
be assigned to the turbines in the Mapping View.  More than one turbine type can be 
used in the same project, provided there are wind resources at the hub heights of each.  

• For details of  the entries in Turbine Studio, see the User Manual and Help files 

WINDFARMER TUTORIAL FOR BASE MODULE 17 



CHAPTER 3 WIND FARM ENERGY ASSESSMENT 

3.5 Define the wind conditions 
To allow the calculation of the wind farm’s energy yield, data on the wind conditions must be 
loaded.  This is done by creating an anemometry mast where the conditions were measured. 

Step 27. Enter Anemometry Mast mode  

Step 28. Right-click somewhere on the map (it doesn’t matter where) to create a mast. 

Step 29. Return to working mode , and right-click on the mast.  Select “Anemometry mast 
properties”. 

 

Step 30. The Mast Properties window will open.  Enter the coordinates of the mast, and a 
name:  ‘Site mast’, Easting 337145, Northing 652387. 

 

 

 

Step 31. Click “Load frequency distribution”, and open the file “Demo.tab”.  A message will 
warn that the default turbulence intensity at mast height is set to be 10%.  Click 
OK.  Changes to the default value can be carried out later. 

Load Frequency Distribution 

Wind Shear Model 

Name and 
Coordinates 
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About Wind Speed Data 

The wind speed frequency distribution of a point holds statistical information on how often 
any combination of wind speed and direction can be expected to occur.  It is the most 
important product of a wind speed measurement campaign, and is used by WindFarmer to 
calculate how much energy a wind farm will generate. 

If wind speeds have not yet been measured on site, approximate data can usually be found 
on publically available wind atlases and web sites.  This is usually in the form of a mean 
wind speed value, or a pair of Weibull coefficients.  Using the “Generate” button, these 
can be directly entered into WindFarmer, which can then generate an estimate of the wind 
speed frequency distribution. 

Step 32. Click on to the “Wind shear model” tab.  Leave the Shear Model selected to “Log 
Law”, and enter a Roughness Length of 0.05m. 

The wind shear model is used to calculate how wind speed changes with height above ground 
level.  It makes the adjustment between wind speed at sensor height on the mast, to wind speed 
at turbine hub height.  Note that if you select WAsP as the wind flow model in  Step 34, then 
WAsP will over-ride the selection made here. 

Step 33. Click “OK” to close the Wind Studio window. 

Step 34. Open the control panel , and go to the “Flow Model” page.  Select “Simple 
model with mast-specific shear” as the flow model. 
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About Wind Flow Models 

The ‘wind flow model’ is the part of the software which is used to calculate how wind speeds 
change across a site, and at different heights above ground level.  WindFarmer is integrated 
with a choice of two wind flow models: 

• The ‘Simple Model’ is included with the WindFarmer Base Module.  This makes simple 
assumptions about wind flow, but on simple terrain gives results which are good enough 
to be used for feasibility studies. 

• WAsP is a more sophisticated flow model which is commonly used within the wind 
energy industry.  It is produced by DTU Wind Energy, and once a licence for it has been 
purchased, it can be controlled directly from WindFarmer. 

Other wind flow models are available, most notably ones based on computational fluid 
dynamics. The output from these models can be loaded into WindFarmer in the form of 
*.WRG files. 

Step 35. Re-open the Wind Studio by clicking .   This is an alternative way of opening 
the window which you earlier opened using “anemometer mast properties”. 

 

 

 

Step 36. Select “Use association method”.  The Association Method is a process used by 
WindFarmer to ensure that the data in the wind speed frequency distribution is 
used as fully as possible.  See the User Manual for more information. 

Step 37. Click on “Auto setup wind resources”.  This tells WindFarmer that it will need to use 
the wind flow model to calculate wind speeds at the turbine locations and hub 
heights.  

Step 38. Click “OK” to close the Wind Studio. 

Step 39. Open Project Properties  

Use Association 
Method 

Auto setup wind 
resources 
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Step 40. Select “Turbulence Intensity” page.  Here, the ambient turbulence intensity is 
entered, for input to the Eddy Viscosity wake model.   

If the Turbulence Intensity Module is not included in the package the only two 
options are to set a “Global value of turbulence intensity” at the mast (in this case 
at 27 m) or alternatively to “Derive the turbulence from the site roughness” set in 
the Energy page of the Project Properties.  In this exercise set a global turbulence 
intensity of 12.5 % and press “OK”. 

IMPORTANT:  Users of the demonstration version of WindFarmer will not be able to run the 
wind flow model calculation.  You should go to  Step 42. 

Step 41. Users of a licensed version of WindFarmer should now run the wind flow model 

calculation, by clicking  or selecting Calculate menu > Update Wind Flow 
Simulation. 

 The wind speed at hub height at the turbine and mast locations will now be calculated.  The 
results can be seen as coloured dots on the turbines.  Now go on to section  3.6. 

 

Step 42. Users of the demo version can load in the results of the wind flow calculation.  

Open Wind Studio again : 

 

 

 

Step 43. Load a “sensor wind resource” and select the file “Demomast_SensorHeight.wrg”. 

Step 44. Click on “New hub height wind resource at turbine”.  The following window will 
open: 

Load sensor wind 
resource 

New hub height wind 
resource at turbine 
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Step 45. Click on “Load…”, and select the file “Demo.wrg”. 

Step 46. “OK” to close the Wind Studio.  

3.6 Running the energy calculation  

Step 47.  As in chapter  2.4, select the Eddy Viscosity wake model in the Control Panel .  
Save the workbook using File menu  > Save Workbook As…  (you will need it 
again in chapter  4). 

Step 48.  Run the energy calculation using the Test button    and export the results.  

 
   End of the exercise 
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4. OPTIMISING THE TURBINE LAYOUT 
In this exercise you will learn: 

• how to carry out optimisation of the layout to maximise the energy yield 

• how to set up the constraints to use for the optimisation 

• how to use the graphing window to monitor the optimisation progress 

• how to handle objects in the map and display maps in the mapping window 

The Optimisation process aims to find the turbine layout that gives the highest possible energy 
output for a given number of turbines whilst taking into account wake effects and constraints 
that may be technical or environmental.   

The procedure that follows refers just to the relevant steps.  It continues with the workbook 
started in chapter  3. 

4.1  Working with the Mapping Window 
 

The workbook contains a layout of 6 turbines within two boundaries.  

Earlier exercises describe how to build workbook files and understand boundary and other 
settings.    

 

Step 1.  To make the turbines more visible, untick the “DTM” and the “terrain” in the “Map 
data” bar on the left of the workspace. 
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About Display Bar and Mapping Functions: 

• Tick boxes in the Map Object part of the Display Bar enable elements in the Mapping 
view to be hidden or displayed.  The appearance of the objects can be modified in 
Control Panel > Map Object page and using the Icon scaler in the Information panel on 
the right.   

• Tick boxes in the Map Data part of the Display Bar enable colour maps and contour 
displays to be shown.  For ZVI, Noise and Shadow Flicker maps, settings need to be 
confirmed in the relevant Control Panel pages before triggering the calculations.  The 
appearance of the displayed maps can be modified in Control Panel > Map Data page. 

• See Help files and User Manual for more detail.  
 

4.2 Calculate the wind resource grid 
In chapter  3 you used the wind flow model to calculate the wind speeds at the turbine 
locations.  The optimiser will change the turbine locations, so before it is run it is necessary 
to calculate the wind conditions across the whole site.  This involves defining a ‘wind 
resource template’, and then calculating the wind speed values which fill that template. 

IMPORTANT: Users of the demonstration version of WindFarmer will have loaded the wind 
resource grid in  Step 45 of chapter  3.  You should go straight on to section  4.3. 

Step 2. First, you can delete the hub height wind resources that you calculated in chapter 
 3.  Right click on the anemometer mast, and select “Anemometry mast properties”. 
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The Wind Studio will open. 

Step 3. In the Mast Properties Browser section, select “Hub-height wind resource: 46m, 
Template”.   

 

 

 

 

Step 4. At the top of the window, click on “Unload” hub-height wind resource at turbine.  
The 46m wind resource will be removed from the list. 

Step 5. Repeat  Step 3 and  Step 4 for the 50m template.  Click “OK” to the warning 
messages reminding you that a WRG file needs to be loaded. 

Hub-height wind 
resource 

Unload hub-height 
wind resource 
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There will now be no hub-height wind resources listed for the mast. 

 

The next step is to define a template of the wind resource grid which will be used to calculate 
the wind speed at hub height across the whole site area.  This can be done by entering 
coordinates into the Wind Studio, but instead this time you will do it by marking the area on 
the map. 

Step 6. Click “OK” to close the Wind Studio. 

Step 7. Right click on the anemometer mast, and select “Define wind resource template”. 
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Step 8. Holding the left mouse button, drag a square so that it encloses the two 
boundaries.  This will be the area for which wind conditions will be calculated. 

 

Step 9. The window which opens allows you to precisely define the area of the wind 
resource template, and also to set the hub height for which it will be calculated.  
Tick the box marked “Calculate entire grid”, and then click “OK”. 

 

To avoid potentially lengthy calculations, WindFarmer by default will only calculate the wind 
conditions at turbine locations.  To run the optimiser, it is necessary to have first calculated 
wind speeds across the whole site.  This is achieved by selecting “Calculate entire grid”.   

The wind resource template is now correctly generated.  The wind flow model can be run to 
fill the template with calculated wind speed data across the site. 

Step 10. Run the wind flow model calculation by clicking  or selecting Calculate menu > 
Update Wind Flow Simulation. 

Wind resource 
template area 
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4.3 Setting up for optimisation 
Before running the optimiser, the settings for energy analysis and for environmental 
constraints must be defined and entered.   Settings in Project Properties and Turbine Studio 
have already been described.  

Step 11.  Open the Control Panel with the Control Panel button  or using View menu > 
WF Control Panel. 

Step 12.  Select the “Energy” page.  For optimisation, select the Modified PARK model as 
the wake model.  Note the Modified PARK Model is recommended for optimising 
due to the faster calculation time compared with the more sophisticated Eddy 
Viscosity model.   Press APPLY. 

 

Step 13.  Now select the Optimiser page of the Control Panel to inspect the constraints.  For 
this exercise, do not alter the settings in this page.    

Constraints can be set for turbine spacing, ground slope, noise limits at individual dwellings, 
visibility from viewpoints, and intervisibility with radar stations.  The page also allows a 
distance weighting to be used during optimisation.  Full information about the Optimiser is 
given in the Help files and User Manual.  

Before starting the optimiser, open a window to show the progression of the optimisation:
   

Step 14. If it is displayed, hide the wind energy map by unticking “Wind Energy” in the Map 
Data panel.  

Step 15. Open a New Graph Window with the button  or select View Menu > New 
Graphing Window.  By default, the graphing window shows the Optimisation 
Progress and the “Graphing toolbar” becomes active on the right. 

Step 16.  Click the Tile Windows button  on the Main toolbar to display both the graph 
and map on the screen.   
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4.4 Running the optimiser 

Step 17.  Click the Optimiser Start/Stop button  on the main toolbar.  This panel appears 
where you can check the settings are as expected.  

 

Step 18.  Press YES to start optimisation or NO if you realise that some further settings have 
to be implemented.  

 

Step 19.  During optimisation you can monitor energy increase, changes in turbine location, 
number of iterations and performance of individual turbines using the 3 panels. 

Step 20. To suspend the process, click the Optimiser Start/Stop  at any time.  You can 
then stop or continue optimising. 

Step 21.  Press YES to stop. 

Step 22.  The number of iterations and the improvement in yield is displayed.  
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Step 23.  Press OK.  A results spreadsheet appears.   

Step 24. Close the spreadsheet and the Graphing window. 

Step 25.  In Control Panel > Energy Page, switch to Eddy Viscosity wake model.  Press Test 

 to calculate the more accurate energy yield for this layout.  

Step 26.  Export the report by pressing “Generate Report” on the left bottom corner of the 
results spreadsheet. 

Step 27. From File menu > Export > Export Data, select Turbine data to export a WOT file of 
the improved turbine locations.   The user can then return to the optimised layout if 
needed. 

End of the exercise
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5. USING THE PROJECT MANAGER  
In this exercise you will learn: 

• how to set up two separate projects in one workbook 

• how to import and export object data 

The “Project Manager” allows the user to include more than one wind farm project in the 
same workbook, making it possible to separate the analysis of one wind farm from the 
others, and to derive either separate or combined results.  

This functionality can be useful, for instance in evaluating the wake effects of a pre-existing 
wind farm on a planned wind farm; evaluating the cumulative environmental effects of 
several wind farms (eg noise, visibility); and exploring several options for layouts.  

This exercise continues from Exercise 3 which had a final layout comprising 6 turbines in a 
single project, split between two boundary areas, as shown below.   This Project was called 
Demo02 – if necessary you should reopen the workbook containing this Project.  You will 
model the effect of a nearby existing wind farm to the North East. 

 

5.1 Setting up the second project 
Step 1.  Click the Project Manager button  on the Main toolbar or select View menu > 

Project Manager. 

Step 2.  Click “New” on the top right corner of the “Project…” window. A new project will 
appear on the window named “Project Name”. 

Step 3.  Left click on “Project name” to highlight it, and then right click to show the options 
dropdown menu.  
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Step 4.  Click on “Rename” and call this neighbouring wind farm “Existing”. 

Step 5.  Right click on “Existing” and select “Make current”. 

By doing this you are now focused on the new project where you must load all the project-
specific inputs (Wind resources, Turbine Types, Project Properties etc.).   

Step 6.  Click OK to close the Project Manager window.   

WindFarmer will warn you that a WRG file will need to be loaded for the new project.  Click 
on “OK”: 

 

In the Mapping view, note how the boundary lines of “Demo02” and its WRGs are hidden.  
The name of the Current project is displayed at the top of the Information bar on the right.   

5.2  Loading data into the second project 
For each Project in the Workbook, the turbine types in Turbine Studio and the settings in Project 
Properties must all be entered separately.   

Step 7.  Insert a boundary to the North East of the first wind farm, using the New Boundary 
mode.  
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5.3  Loading the turbine layout of the nearby wind farm  
Step 8.  Assume the existing nearby wind farm consists of 3 turbines of known coordinates. 

These coordinates can be imported into WindFarmer as a text file with extension 
*.WOT, listing how many turbines there are and then the X,Y coordinates as 
shown below.  For example: 

 

Using a text editor such as Notepad, create this file and save in TXT format in the 
Demodata directory, with filename “Existing.TXT”.  Change the extension to 
“.WOT”.  

This is a simplified form of the text files of object data that can be exported from WindFarmer.   
 

About data export from WindFarmer: 

• Most object data and many results in WindFarmer can be exported as ASCII files that 
can be read with any text editor.  Similarly such files can be created and used for 
import, thus allowing interface with other software such as GIS systems. 

• Use “File menu > Export > Export data” to select the object data required.  Data can be 
exported from “all” Projects or just the “current” Project.   

• An Appendix of the User Manual describes the multiple columns of data that are 
exported for each type of object. 

   

Step 9.  Use Load File to load “Existing.wot”.  

WindFarmer will issue the following warning, to which you should reply “Yes”: 
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The turbines will be imported, provided their locations lie within the boundary.  Note that the 
Turbine Type still needs to be assigned.   

  

Step 10. Follow the steps in chapters  3.4 and  3.5 to set up the project properties, turbine 
specification, and wind conditions for this “Existing” project.  In this case you will 
make the same settings as for the first project you created, but in practice 
neighbouring wind farms will often use wind data from different ma  

5.4  Running the energy calculation 
Step 11.  Go back to using “Demo02” as the current project by opening Project Manager,  

. 

Step 12.  Left click on “Demo02” to highlight, right click to view the options and left click on 
“make current”.  Press OK.  Alternatively, in the Mapping View you can double-
click on an object in “Demo02” for the option to switch.  

Step 13.  Select the required settings in the Control Panel Energy and Optimiser pages. 
These settings are global and apply to all active projects.   

Step 14. Run the energy calculation for all turbines of the active projects “Demo02” and 
“Existing” by pressing . 

Step 15.  Close the Excel spreadsheet displayed over the workspace.  The information 
panel summarises the energy yield for all projects and for the current project. 
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Step 16.  Go to File > Generate Report. The window below appears 

 

Step 17.  From the “Report Generator”, select Generate Energy & Turbine Results Report.  
The report contains the combined results from both projects, and then lists the 
separate results for each project.   

Step 18. To export just the results from the Current Project, return to the report generator 
window using File menu > Generate Report and select the Current option:  

 

To carry out an energy calculation for one project without taking the other project into 
account, make the second project “Inactive” in Project Manager by right-clicking on it.    

  

When a project is inactive, the elements are completely hidden in the Mapping view.   They 
take no part in any analysis.   

   End of the exercise 
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6. USING PROJECTIONS AND 
SHAPEFILES 

In this exercise you will learn: 

• How to define the map projection used in your workbook 

• How to load boundaries from Shapefiles 

• How to load objects from Shapefiles 

6.1 Selecting the map projection 
It is not essential to define the map projection of your workbook – if all your data is in the 
same projection, then WindFarmer will function quite successfully without doing so.  
However, certain features such as shadow flicker calculations and compatibility with Google 
Earth do require the projection to have been defined. 

Step 1. Open an empty Workbook in WindFarmer using the New Workbook button  or 
File Menu > New Workbook.  Alternatively, a new Workbook will automatically be 
created when WindFarmer is first started.   

Step 2. Open the Control Panel with the Control Panel button  or using View menu > 
WF Control Panel. 

Step 3. Select the Preferences page, and tick “Enable coordinate projection selection”.  
Then press OK. 

From now on, every time some map data is loaded, WindFarmer will ask which projection it 
is in (unless the file is supplied with projection data, such as a PRJ file). 

Step 4. Using the Load File button  on the Main Toolbar, load “Demo.map”.  The Source 
Data Projection selection window will open.  Set the projection to “British Grid” and 
the datum to “OSGB36 (Best Transform)”, as shown below: 
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6.2 Loading Shapefiles 
The coordinates of WindFarmer objects, boundaries and contours can be imported from 
ESRI Shapefile format files.  Some example shapefiles are provided in the “shapefiles” 
subfolder of Demodata.  Note that these files are supplied with PRJ projection metadata 
files, and so WindFarmer will not need to ask the user to specify the map projection. 

Step 5. Using the Load File button , open the file “southern boundary.shp”. 

Step 6. In the “Assign a type” window, select “Boundaries”. 

 

Step 7. The boundary stored in this file represents the site limits for this example.  This is 
the area in which turbines can be installed.  In the “Import Boundaries” window, 
define the “Type of Interaction” as “Contains Turbines”, and click OK. 

 

The shapefile will load into the map.  The file is composed of a single polygon with a hole in 
it.  The outside of the polygon is converted into a boundary which can contain turbines.  The 
hole is converted into a second boundary, which is set to exclude turbines.  For a full 
explanation of how WindFarmer treats holes in polygon data, see the User Manual. 
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Step 8. Now load the file “Footpath exclusion area.shp”.  This file contains an area from 
which turbines will be excluded, due to the presence of a footpath.  Again, select to 
Interpret data as Boundaries. 

Step 9. In the “Import Boundaries” window, set Type of Interaction to “Excludes turbines”, 
and “Treatment of polygon holes” to “Join hole to outer boundary”. 

 

This shapefile is loaded into the map.  Note how the exclusion areas are automatically cross-
hatched. 
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Step 10. Load the file “southern turbines.shp”.  This contains the coordinates of some 
turbines, so when prompted select to Interpret data as “turbines”. 

 

 
   End of the exercise 
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