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1. INTRODUCTION  
The aim of this tutorial is to help the user gain familiarity with the features provided by the 
modules of WindFarmer which are not covered elsewhere. The modules that are presented in 
this tutorial are:  

• MCP+ Module 

• Turbulence Intensity Module 

• Electrical Module 

• Shadow Flicker Module 

• Financial Module 

Most of this tutorial can be followed by a user with the demonstration version of WindFarmer.  
Users with a licensed version of the software should note that in order to function these modules 
also require the Base Module. 

These tutorials are a supplement to the User Manual and the Theory Manual of WindFarmer. 
The user should refer to these for more information. 

The exercises use sample files provided in a folder called ‘Demodata’, which can be found in 
Libraries\Documents\WindFarmer.  Users of Windows XP can find this folder inside the 
WindFarmer installation directory, which is usually C:\Program Files\WindFarmer. 

Throughout the tutorials, we recommend you save your work from time to time.  However, note 
that Workbooks cannot be saved from the WindFarmer demonstration version.   
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2. MCP+ MODULE 
The MCP+ Module contains the tools needed to take raw time series of wind speed and 
direction data through data assembly, cleaning, calibration and correlation to produce the wind 
regime at your site in the form of a wind speed and direction frequency distribution. See Section 
4 of the User Manual for more details. 

2.1 Loading time series 
The following steps explain the process of loading raw time series meteorological data into 
WindFarmer. The MCP+ module acts as a database to store time series data from all of the 
masts on a project site and any long-term reference data sets considered as well. 

Step 1.  Click  on the main toolbar or go to File > New Workbook to begin with a blank 
workbook. Cancel the Wizard window if it opens. 

Step 2.  Click  or go to File > Load MCP+ data.  

Navigate to the Demodata folder in the WindFarmer library and open the file 
“Reference.txt”. The file “Reference.txt” contains raw data as recorded by a data 
logger on a met mast, and this data set will be the long-term reference data for this 
tutorial. This simple example file comprises four columns of data featuring date, 
time, wind speed and direction. MCP+ can handle many other types of data 
generated by standard data loggers. 

Click Open. The dialog box below will appear. 
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Step 3. Click Next. The window below will appear as step 1 of the process. Here the user 
can load in a *.wldst file, if one was previously created, that contains all the load 
settings based on the structure of the input file. In this example there is no 
previously created settings file, and the settings will be entered manually in the 
following steps. 

 

Step 4. Click Next, and Step 2 of the Data Loader will appear. Here the user sets the row 
at which to start the import. This is important if the data file contains header 
information in the first rows. In this case, “Reference.txt” has one row of header 
data, so set ‘start import at row’ to 2. 

 

Step 5. Click Next. At Step 3 of the Data Loader, set the delimiter type. In this case the file 
has tab delimiters. Check the box labelled “Tab”. 

Step 6. Click Next. At Step 4 of the Data Loader, associate a data format to each column of 
data. Click anywhere in column 1 to highlight the column. Since the first column 
contains the date information, select the radio button labelled “Date” as the data 
format. Check that the format specified matches the data set. The “Reference.txt” 
data set has data information in “ddmmyyyy” date format.  

Note: Different models of data loggers produce raw data with different time 
stamps. MCP+ will accept the typical data settings of the most common data 
loggers used in the wind industry; just check that the date format is set 
appropriately at this step in the Data Loader. 
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Step 7.  Select the second column of data. Select the radio button labelled “Time” to 
associate the time format. Ensure the format matches the data set, and in the 
“Timestep” box, enter the time step increment. In the “References.txt” file, the time 
format is “hhmm” and the time stamps have 60 minute increments.  

Step 8. Select the third column of data. This is a wind speed signal, so select the “Signal” 

data type. Click the drop down box for the mast  and select 
“<new>” to open the window below 

 

Step 9.  Enter “Ref_mast” as the mast name, “Reference mast” as the description, and the 
coordinates (56.0°N, -3.4°E) for the mast. Note that entering a description and 
geographic coordinates are optional. Click OK. 

Step 10.  Now, in the same way, create a new sensor from the Sensor drop down box. 
Anemometer, wind vane, pressure, temperature, battery voltage or any other 
sensor specified by the user can be analysed in MCP+. In this specific exercise 
enter “speed” as the sensor name, select “Anemometer” as signal type and set a 
height of 10 m. Note that WindFarmer has automatically chosen sensible minimum 
and maximum data values based on the sensor type, although these can be 
changed if necessary. Click OK. 

Step 11.  Specify the signal type in the last drop down box (options are mean, standard 
deviation, max, min or flag). In this data set, column 3 represents the mean value 
of wind speed.  
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Step 12.  Click in column 4. Select the “Signal” radio button to register column 4 as another 
sensor. In this data set, we know that column 4 belongs to Ref_mast. Input a new 
sensor using the drop down box. In the New Sensor dialog box enter “dir” as 
sensor name (for wind direction) and select “Wind Vane” as signal type. Set a 
height of 10 m. Click OK.  

Note: MCP+ can handle as many columns as the raw data contains. If the data set 
contained additional columns, the process for loading in these data would be the 
same as described here in Steps 8 – 12. 

Step 13.  Once all of the columns of the file are defined, click Next. Step 5 of the Data 
Loader will appear as shown below. Sometimes the scale factor and the offset 
applied at the logger for the conversion of the frequency signals to wind data do 
not reflect the values that should have been applied (i.e. calibration factors, 
consensus calibrations, technical specifications, etc.). Sometimes the requirement 
may simply be to convert a wind speed signal from one unit to another. Whatever 
the reason, Step 5 allows the user to change the calibration upon loading. Sensor 
calibrations can also be edited after the data have been loaded. In this case, no 
adjustments are going to be applied to the calibrations at this stage. 

 

Step 14. Click Next. In step 6 of the Data Loader, the user is prompted to save the settings 
given in the previous steps (i.e. delimitation, data format associated to each 
column, calibrations, etc.). Click Browse and enter a name for the settings file, 
then click Save. If you need to reload the data set, these settings could be loaded 
in Step 1 of the Data Loader, allowing you to skip steps 2 to 4 in the loading 
process. This can be very handy when dealing with complex raw data files 
containing many columns of data. 

Step 15. Click Finish to finish the data loading. A dialog box will show the progress of the 
data loading. If inconsistencies are found within the data set, MCP+ will display a 
warning message specifying the column in which the inconsistency occurs. Typical 
inconsistencies are duplicate time stamps, time stamps out of order, variation of 
the total number of columns within the file, etc. After the loading finishes without 
problems, the mast “Ref_mast” appears on the top left corner of the MCP+ 
window, as shown below. 
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Step 16.  Repeat the loading process just described for the site mast file “Site.txt”. Again 
click  or go to File > Load MCP+ data. The file “Site.txt” is also located in the 
same demo data directory. This file has the following columns: Date, Time, Wind 
Speed Mean, Wind Speed Standard Deviation, Wind Direction Mean, and 
Temperature Mean. Call the mast “Site_mast” in the Data Loader, and its location 
as (55.8°N, -3.0°E). Enter appropriate names for the anemometer, wind vane, and 
temperature sensors such as “speed,” “direction,” and “temp.” The wind speed 
measurements are at a 50 m height, and the wind vane measurements are at a 
47 m height.  

Once the loading process is finished the mast “Site_mast” should appear right 
below “Ref_mast”.  
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2.2 Checking and cleaning the data 
Once raw time series data are loaded into WindFarmer, the MCP+ module provides the user 
with tools to review each data set for quality assurance. Time series and correlation plots help 
identify erroneous data from, for example, failing or malfunctioning sensors, logger issues, and 
icing events, and these data can be easily removed within the MCP+ module. The steps below 
describe the tools available for reviewing and removing data and changing sensor calibrations. 

Step 17. Click  in the MCP+ toolbar or go to MCP+ > Exclude Data > Data Cleaning… 
and the following Data Cleaning window will appear.  

 

Step 18. Use the ‘+’ symbols next to the mast and sensor names to expand the tree 
structure and reveal the sensor signals. Left click on the sensor signal to be 
plotted. To select more than one signal, hold the ‘Ctrl’ key while left clicking each 
sensor. Click the ‘>’ button to move the mean wind speed and direction signals for 
Ref_mast and Site_mast into the Configuration window.  

Step 19. At left hand bottom of the window, select the Sensors tab to view the time series 
plots. A graphing window similar to the following will appear. 
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Step 20. When in the plotting window, use the scroll wheel on the mouse to zoom in and out 
of the data. Alternatively, select a period of data, right-click, and select Zoom to 
Selection. Scroll to different periods of data by using the keyboard arrow keys or 
by the scroll bars at the bottom of the Data Cleaning window. To return to the fully 
zoomed-out view, click the  button at the left of the scroll bar. 

Step 21. To remove defective data from the analysis, use the left mouse button to select and 
drag the mouse across a period of data on the Sensors tab plots. The selected 
section of data will be highlighted purple. Release the mouse button, and left click 
the checkbox on the left margin corresponding to the signal whose data should be 
removed. This will highlight the selection to be excluded in red, as shown below. 
Right click within the red highlighted area, and select Exclude Data. 

 

Step 22. The following Exclusion Details box will appear. It presents the time range for the 
exclusion and offers a drop down menu of choices to assign an explanation for 
why the data is being excluded. Use the Edit Reasons button to add a custom 



CHAPTER 2 MCP+ MODULE 

WINDFARMER TUTORIAL FOR OTHER MODULES  9 

reason to the list. Once the reason has been selected, select the Apply button to 
exclude the data selection from the data set. 

 

Step 23.  Select the Grid tab at the bottom left hand corner of the window. This tab displays 
the sensor signal data in a spreadsheet. Data can be excluded in this view, 
following the same steps just described.  This time you select the signal to be 
excluded by clicking on the column header. Data that have been excluded appear 
as light blue text.  

Step 24.  Go to the Signals tab. Here signals of the same type are plotted together for easy 
visual inspection of the data. Again, use the same techniques described in Step 20 
above to zoom in and out of the data and scroll to different sections of data. Note 
that data cannot be excluded from the Signals tab; return to the Sensors or Grid 
tabs to exclude any additional data.  

Step 25.  Return to the Config tab. Click the Add Correlation button at the bottom of the 
window. Use the drop downs for the X and Y Axes to select two sensors to 
compare. In this case, select the Ref_mast and Site_mast wind speeds. Click the 
Add Correlation button again and then select the Ref_mast and Site_mast wind 
directions, as shown below. 

 



CHAPTER 2 MCP+ MODULE 

WINDFARMER TUTORIAL FOR OTHER MODULES  10 

Step 26.  Go to the Correlate tab to see the correlation plots. Data that are poorly correlated 
may indicate erroneous data at one or both sensors. The zoom level in the 
correlation plot corresponds to the zoom level in the Sensors and Signals plots. It 
may be useful to begin at the most zoomed-out level to view the correlation of the 
full period of concurrent data. Then zoom in to the time series on a weekly or 
monthly level and step through the data, using the Page arrows at the bottom of 
the screen, to identify periods where the correlation changes. If the Show 
Exclusions checkbox at the bottom of the window is checked, any data that have 
been excluded are displayed in orange, as shown below in the bottom plot. 

 

Step 27.  Close the Data Cleaning window. This saves all data exclusions made. 

Step 28.  Data cleaning can also be applied based on the values of certain signals. Click 
 or go to MCP+ > Exclude Data > By Value… to apply a filter to a certain 

sensor signal output. Set the filters to exclude wind speed data from Site_mast 
when the wind speed standard deviation is less than 0.01 and label the exclusions 
as “Sensor failure”, as shown below. Click Apply to exclude the data identified by 
that filter.  
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Step 29.  Click the View Exclusions… button to view all exclusions that have been applied to 
the data, both from this and the Data Cleaning window.  We have been quite 
careless in the way that we have excluded data during this tutorial, so you should 
now delete all the exclusion records you have created.  This will return the data to 
the state in which it was loaded. Press Ctrl-A to select all exclusion records and 
click the Delete button to remove all exclusions. Close the Exclusions List and 
Exclude Data By Value windows. 

Step 30.  To change any of the calibrations applied to the sensors in the loaded data sets, 
open the Calibrations window by right clicking the mast or sensor name in the 
MCP+ window, or alternatively, go to MCP+ > Edit > Calibrations in the top 
toolbar. Once in the Calibrations window, right click the row of the sensor to be 
edited, and select one of the options listed: Edit Calibration, Split Calibration, or 
Merge Calibration. 

Step 31.  Go to the MCP+ > Edit > Mast, Sensors, and Calibrations options in the top 
toolbar to review the settings applied to the loaded data sets. The same dialog 
boxes can be accessed by clicking ,  and  on the MCP+ toolbar, 
respectively.  
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2.3 Exporting data and frequency distributions 
Once you have cleaned and calibrated your data, you may want to export statistics about it, or 
create a wind rose or frequency distribution. 

Step 32. Right click on the Site_mast > Speed > Mean signal in the MCP+ data tree, and 
select “Export Statistics…” 

 

Step 33. Enter a filename and save the file.  This creates a short text file which contains a 
summary of the data which has been measured at the site mast. 

Step 34. Open the file you have just created in a text editor or Excel. 

 

The “ExportStats” file summarises measured data.  It shows you both mean values and data 
coverage, and will help you to judge the quality of your wind measurement campaign. 



CHAPTER 2 MCP+ MODULE 

WINDFARMER TUTORIAL FOR OTHER MODULES  13 

Step 35. Click  or go to MCP+ > Frequency distribution to create a wind speed and 
direction frequency distribution. The dialog box below will appear. 

 

Step 36.  Select Site_mast as the mast for wind speed and direction. In this case it is not 
necessary to specify the wind speed and direction sensors to use since there is 
only one of each type of signal loaded in Site_mast.  

Note this window provides three export options: .TAB file, wind rose, or .WTI file.   

Step 37. To export the wind speed and direction frequency distribution as a .TAB file that 
can be used in flow models to calculate the representative wind flow over the wind 
farm site, select the radio button labelled “Export .tab file” and choose the number 
of wind direction bins from the drop down menu. The standard number of direction 
bins is 12. There is also an option to “Remove seasonal bias” which is by default 
turned on. Click Export and a Save As box will prompt the user for the folder in 
which to save the file.  

Step 38. To export the wind speed and direction frequency distribution as a wind rose, 
select the radio button labelled “Create wind rose”. There are options to customise 
the number of wind direction bins and the number and width of the wind speed 
bins. There is also an option to “Remove seasonal bias” which is by default turned 
on. Click the Export button and a window will pop up automatically generating the 
wind rose as shown below. Right click the window to name, edit or save the wind 
rose. 
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Step 39.  The “Export .wti file” option allows the creation of a .WTI file.  This records the 
turbulence intensity at the mast as a function of wind speed and/or direction, and 
can be used by WindFarmer for turbulence intensity assessments at turbine 
locations. For this function to be available, the anemometer must have measured 
the standard deviation of wind speed, and the user requires a licence of the 
WindFarmer Turbulence Intensity module 

Step 40. Close the Frequency Distribution window. 
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2.4 Running an MCP analysis 
The next steps explain how to apply the MCP (Measure Correlate Predict) methodology. The 
target is to start with the reference mast and use the correlation of the reference mast to the site 
mast to derive the long-term frequency distribution .TAB file at the site mast. In this operation 
the user can also assess the quality of the correlation by evaluating, both graphically and 
numerically, the scatter between the concurrent data at the two masts in the 12 direction 
sectors. 

These steps describe the mechanical process of running the MCP analysis in WindFarmer. 
Refer to the Theory and User manuals for more information on the theory behind the process.  

Step 41. Click  or go to MCP+ > MCP…. A dialog box will appear as shown below.  

 

Step 42.  Using the drop down boxes, select “Ref_Mast” as the reference mast and 
“Site_Mast” as the site mast. In this case each mast has only one wind speed and 
one direction sensor. If this is not the case, the user can use the other drop down 
boxes to select the required sensors.  

Step 43.  In the Correlation Settings box, in the lower half of the window, the user can adjust 
settings for the cut off wind speeds used for the correlation analysis; the method 
for assessing the correlation scatter; whether to force the linear fit through the 
origin, and the number of direction bins to be used in the correlation analysis. 

Note that options for setting cut offs to remove very low or high wind speed data 
from the correlation are provided because anemometer accuracy may be reduced 
at those wind speeds. Use judgment in changing the default values. Note that 
even with cut off low and high wind speed values, the low and high wind speed 
data will still be used in to synthesise data; they just will not be built into the 
correlation.  

Step 44.  Click Next. MCP+ will take a few seconds to process and then will produce the 
window shown below. Note that the spreadsheet on the left contains the following 
information: centre points of wind direction sectors, speed up between reference 
and site (in this case the site mast is windier than the reference mast), Offset (in 
this case the line is forced through the origin), Pearson’s r (correlation coefficient 
as an indicator of the level of scatter) and number of concurrent data records of 
the two masts that contributed to define the correlation. 
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Step 45.  Click the Plot button to view the quality of the correlation. The window below will 
appear showing the correlation in the various direction sectors. At the bottom of 
this window, use the page buttons to switch to the other correlation plots for the 
other direction sectors and the direction correlation. These images can be saved, 
if desired. Close the window to return to the previous dialog box. 

  

Step 46.  Click the Export Trend button in order to export a file documenting the proposed 
speed up values by direction sector. 

Step 47.  Click the drop down menu labelled “Apply speed trends” on the right hand side of 
the window to select to apply the directional speed ups calculated.  

Step 48.  Click Next. The MCP – Direction Trends window appears as shown below. Similar 
to the MCP – Speed Trends window, the Plot button allows the user to view and 
export the correlations, the Export Trend button allows the user to save the 
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calculated offset values, and the drop down menu labelled “Apply direction trends” 
can be used to select how directional speed ups are applied.  

 

Step 49.  Click Next. The MCP – Exports window appears as shown below. Select the radio 
button labelled “Long-term tab file from reference time series”. 

 

Step 50.  Under the Settings box, there are options to “Splice measured site data into long-
term prediction” and/or “Remove seasonal bias in tab file.” These are selected by 
default. The spliced time series is the combination of the synthesised data created 
from the reference mast data, which have been factorised using speed ups and 
direction shifts from the correlation, and the measured data at the site mast. In the 
case when the splice time series box is unchecked, the time series will contain 
only the data synthesised on the site mast and none of the actual measurements. 

Step 51.  Select how to split the data into direction bins with the drop down menu labelled 
“Bin settings.” When finished making the selections, click the Export button and 
choose where to save the .TAB file.  

Step 52. Close the MCP window.  End of the exercise. 
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3. TURBULENCE INTENSITY 
MODULE 

The Turbulence Intensity Module gives the user increased capabilities when inputting the 
turbulence intensity characteristics. It allows the turbulence intensity to be input as a function of 
wind speed and/or direction. This is particularly beneficial to users with the MCP+ Module, 
which can derive turbulence intensity data from wind speed measurements. The Turbulence 
Intensity Module also provides the user with access to the individual turbine data generated 
during the energy calculation, including turbulence intensity values calculated in the Eddy 
Viscosity Wake Model.  This allows users to determine the turbulence intensity due to the 
turbine wakes at each wind turbine in the wind farm layout.  The data generated can be 
exported via the Flow and Performance Matrix.   

See Section 8 of the User Manual for more details.  

It should be noted that this exercise requires the full version of the software, and cannot be 
completed with only the demo software. 

3.1 Advanced turbulence input 
Step 1. Open the file “Demosite.wow” located in the demodata directory of the WindFarmer 

library. Refer to the Base Module Tutorial to understand how the WOW file has 
been created. 

Step 2. Click  or go to “View > Project Properties”. The “Project Properties” window with 
multiple dialog boxes will appear. 

Step 3. Click on the “Turbulence Intensity” tab. The window below will appear. 

 

Step 4. The value of turbulence intensity set in “Demosite.wow” is a default global value of 
12%. Click on the drop down box to display and familiarise yourself with all the 
different options of turbulence input. 

Step 5. For this specific exercise we want to set turbulence intensity as a function of wind 
speed. Select this option from the pull down menu. Edit the configured 
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spreadsheet with arbitrary values starting with 80% at 1m/s and dropping by 5 % 
every 1 m/s (80%, 75%, 70%... down to 10% at 15 and 16m/s+). However, in a 
real scenario, these values should be calculated using the wind speed standard 
deviation recorded at the anemometer. Furthermore they decrease following an 
exponential trend rather than a linear trend. Note that turbulence intensity from 16 
m/s and above usually tends to be asymptotic. The following window shows how 
the turbulence input will look. Note that the MCP+ module allows the calculation of 
turbulence intensity, which can be saved as a WTI file and then imported into 
Project Properties. 

Step 6. Press APPLY to store the changes.  

Step 7. It is optional to save the turbulence input by pressing SAVE. A file in WindFarmer’s 
own format (*.wti) can be created. Note that if a WindFarmer turbulence file has 
been created for a specific sensor (usually by using the MCP+ module) this can be 
imported by clicking “Load”. 

 

Step 8. Press OK to close the “Project Properties” window. 

Step 9. Click   or go to “View > WF Control Panel”. 

Step 10. Switch to the “Energy” window. 

Step 11. Set “Eddy Viscosity Model” as the wake model using the drop down box on top of 
the Energy window. Because we entered such high values for turbulence intensity, 
you should increase the “Maximum allowable Turbulence Intensity (%)” in the 
“Eddy Viscosity Model” section of the window in order to perform the calculation 
without warnings of illegal layout. In this specific example you should enter the 
maximum value of 100% - in a real world example the default value of 20% may 
be appropriate. 

Step 12. Press APPLY to store the changes. 

Step 13. Press OK to close the WF Control Panel. 

Step 14. Use “File > Save Workbook As…”  to save the workbook with the changes carried 
out so far. 
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3.2 Exporting the Flow and Performance Matrix 
The Flow and Performance Matrix is only available with a licensed version of WindFarmer.  
Users with the Demo version will not be able to complete this exercise. 

Step 15. Click   or go to “Calculate Energy/Test” to carry out the energy calculation. 

Step 16. Close the “Report” excel spreadsheet displayed at the end of the test. 

Step 17. Go to “File > Export > Export Flow and Performance Matrix”. The window below will 
appear. 

 

Multiple options are available for the type of output (Matrix channel), the turbines for 
which information is required (Project turbines) and the selection of the project. 

For this specific example the target is to know more about the “Turbine Electrical 
Output” broken down for wind speed and direction bins at Turbine 1.  

Step 18. In the “Flow and Performance Matrix Export” window click “2: Turbine electrical 
power (kW)*” on the left section of the window. It will be highlighted in blue. 

Step 19. Click “Add >>” to transfer the highlighted element to the right section of the window. 

Step 20. Click on “Project Turbines” in the “Selection Type” section. The window will display 
the turbines of the project as shown below. 
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Step 21. Click on “1:A1” to highlight Turbine 1.  

Step 22. Click “Add >>” to shift the turbine to the right. 

Step 23. Go to the drop down box of “Select Project” if multiple projects have been loaded in 
the same workbook. This is not the case for the demo WOW file. 

Step 24. Click “Export” to create the matrix. 

Step 25. Save the file as TXT in a suitable directory. 

Step 26. Open the output file in Excel and after applying tab separation check the contents 
of the matrix. In this example the matrix is describing in detail how Turbine 1 
performs in terms of instantaneous power output for each wind speed (rows of the 
matrix) and each wind direction (columns of the matrix).  This is using the wind 
condition at the met mast – ticking the ‘use local wind speeds at each turbine’ 
checkbox in the Export dialogue box will change the reporting to be relative to the 
free stream wind at the turbine location.. 

Step 27. Repeat the previous steps exporting information from other channels. Note that if 
the GH BLADED LINK module is licensed then further channels are available. The 
outputs from these channels are then usable in GH Bladed for loading 
calculations. See the Theory and User manuals for further details.  

End of the exercise. 
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4. ELECTRICAL MODULE 
The Electrical Module allows the user to design the electrical network of the proposed wind 
farm, calculate the electrical performance in terms of losses and reactive power consumption, 
estimate the required lengths of cabling, and so on. 

 See Section 9 of the User Manual for more details. 

4.1 Setting up the electrical network 
Step 1. Open the file “Demosite.wow” located in the demodata directory of the WindFarmer 

library. 

Step 2. Turn off DTM, terrain, boundaries and boundary points in the “Map Object” and 
“Map Data” bar. Note that this is not a requirement - it simply provides a better 
view of the layout, as shown below. 

 

 

 

Step 3. Click  or go to “Add > Cables” in the toolbar. 

Step 4. Cables in WindFarmer run between objects such as turbines or meters, and nodes. 
Right click in the map to add a meter – this is shown as the green square in the 
image below, and represents the point of connection between the wind farm and 
the electricity distribution network. Then right click three more times to place three 
nodes (the green crosses), passing between the groups of turbines 1-2-3 and 4-5-
6..Note that several mouse functions are described in the user manual to help the 
user to draw electrical cables.  

 

 



CHAPTER 4 ELECTRICAL MODULE 

WINDFARMER TUTORIAL FOR OTHER MODULES  23 

Step 5. Connect each of the six turbines to their nearest node. Note that turbines cannot be 
connected to the metering point. In order to do so click  or go to “Modes > 
Cabling”. 

Step 6. Click on node 2 in the Control bar- Information tab located under “Group ID”. 

Step 7. By holding down the control key (Ctrl) left click on turbine 1 and turbine 4. The two 
turbines will be connected to the main cable at node 2. 

Step 8. Click on node 3 in the Control bar- Information tab located under “Group ID”. 

Step 9. By holding down the control key (Ctrl) left click on turbine 2 and turbine 5. The two 
turbines will be connected to the main cable at node 3. 

Step 10. Now click on node 4 in the Control bar- Information tab located under “Group ID”. 

Step 11. By holding down the control key (Ctrl) left click on turbine 3 and turbine 6. The two 
turbines will be connected to the main cable at node 4. The final cable layout 
suggested in this example is shown in the next figure. 

 

 

 

Step 12. Go back to working mode by either clicking  or double clicking in an empty part 
of the workspace. 
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4.2 Editing cable properties 
At this stage, the electrical properties have to be associated to each element of the 
electrical network. Notice that in a real scenario electrical equipment should be chosen with 
careful judgement since all the elements combined (cables, transformers, etc.) should give 
the lowest electrical losses as possible within reasonable costs. It is not scope of this 
exercise to investigate the best equipment but rather give a demonstration of how this 
information is loaded into the model.    

 

Step 13.  Right click over the meter (the square) to display the options shown below 

 

 

 

Step 14. Left click on “Cable properties” to open the “Electrical Module Properties of 
Turbines and Cables” window shown below for this specific project 
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About Cable Properties: 

 

In this window all the settings related to the electrical specifications can be set. In detail: 

 

The left side of the window shows all the connections refereed to the specific node. In this 

case it can be seen that node 2 is linked to node 3, turbine 4 and turbine 1.  indicates 
the wind turbine generator, WTG,  indicates transformer,  is cable and  is root node 
(where the meter is usually located).  

By clicking on each of these elements the user can edit cable (resistance, inductance, 
capacitance, voltage, etc.), transformer (rating, primary voltage, secondary voltage, etc.) 
and generator properties on the right of the window. 

In “Node Navigation” it is possible to switch to the upper node. 

In “Edit” the user can copy properties to be pasted in other similar elements of the project or 
pick up properties directly from a library. 

Meters, Transformers and PFCD can be inserted at any point of the network where 
required. 

Step 15. The properties of the WTG have already been set in “Wind Turbine Studio > 
Turbine Power Curve” ( ). 

Step 16. Click on the cable  between turbine T4 and the transformer  above it. 

Step 17. WindFarmer allows you to maintain a library of electrical components to use in your 
network.  Click “Library” to open it.  To load in an initial set of data, press the 
“Load” button in the “Library” section of the window and select the file 
Elec_Library.elb provided in the Demodata folder of WindFarmer. The library 
below will be displayed.   
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Step 18. Select the 8th ground cable from the top (with size 300 mm²). Note that for this 
example no particular care has been given to the cable selection, only that it can 
support a voltage which is greater than the nominal voltage of the turbine (in this 
case 0.69 kV). 

Step 19. Click the box “Read” on the left bottom corner of the window. 

Step 20. The selected cable will be loaded as shown below. 

 

 

 

Step 21. Click on the  for transformer T4, next to the cable that has been just loaded. 

Step 22. Click “Library” to load a suitable transformer. 

Step 23. Select the top one in the list and press “Read”. The window will now show the 
transformer as indicated below. 

 

 

 

Step 24. Click on the cable above (between T4 transformer and the “next node”) to define 
the cable that will link the transformer of turbine 4 to node 2. 

Step 25. Click “Library” and select the first cable with nominal voltage of at least 11 kV (the 
high voltage side of the transformer). 

Step 26. Click “Read” to load the cable and get the layout shown below. 
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Step 27. Click on any of the three elements that have been just loaded and press “Copy”. 

Step 28. Navigate through the nodes (bottom left of the Electrical Properties window) or the 
turbines (top right of the Electrical Properties window) to “Paste” this information to 
exactly the same tree location for the other 5 remaining turbines (the target is to 
assume same specifications generator-cable-transformer-cable-node).  

Step 29. Now the only information to load is about the main cable from node 1 to node 4. 
Move with the node navigation to node 4 as shown below. Note, from the previous 
step, that all the specifications from the generator to node 4 have been loaded. 

 

 

 

 

Step 30. Click “Library” to access again to the cable library. 

Step 31. Select the last cable in the list and press “Read”. 

Step 32. Copy and paste the specifications of this cable to all the other remaining nodes (3 
and 2) by moving to “Next Node”. 

Step 33. Click “Exit” on the right bottom corner to close the window. 

At this stage all the specifications for the electrical network have been loaded. The demo data 
library has simplified the work of loading data from scratch and can be partly useful for 
addressing users who are inexperienced with electrical issues.  
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4.3 Calculation of electrical losses 
The next step is to calculate the net energy production taking into account the electrical losses 
given by the designed network. 

 Click  or go to “View > Project Properties”. 

Step 34. Switch to the “Energy Efficiencies” window. 

Step 35. In the section “Input Electrical Efficiency” tick the “Calculate” box as shown below 

 

 

Step 36. Press APPLY to store the changes and OK to close the window. 

Step 37. Click  on the mapping toolbar or go to “Calculate > Energy/Test” in the menu. 

Step 38. The spreadsheet report displayed on screen now shows the electrical efficiency 
calculated with the given electrical network. 

End of the exercise. 
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5. SHADOW FLICKER MODULE 
The Shadow Flicker Module contains the tools required to assess the potential period of shadow 
flicker caused by a wind turbine. The module allows you to create maps of shadow flicker 
occurrence and to analyse the shadow flicker at specific points, known as receptors. This 
information can be used to design and operate the wind farm in a way that minimises the 
annoyance to people. See Section 10 of the User Manual for more details. 

5.1 Calculation options 
Step 1. Open the file “Demosite.wow” located in the demodata directory of the WindFarmer 

library. In general note that a DTM map is required in order to run the shadow 
flicker model.  

Step 2. Click  or go to “View > WF Control Panel”. 

Step 3. Switch to the “Shadow Model” dialog box within WF Control Panel. The window is 
shown below. The next steps will provide explanation of each input of this window. 
It is recommended to play with different combinations to understand the behaviour 
of the model.  

 

 

Step 4. The “GMT time zone” is required to know precisely the time zone. This is useful if a 
turbine shut down procedure has to be implemented at some hours of the day to 
minimise the annoyance of shadow flicker at some locations. 

Step 5. The “Defaults for Receptors” inputs can be ignored for now. 
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Step 6. In the “Calculation Options” box there is “Distance limit options” box where it is 
possible to choose the maximum calculation distance from either the centre of the 
project or from the centre of each turbine. 

Step 7. In the input box “Year of Calculation” the user can set the year for which the 
shadow flicker calculation will be carried out. The calculation can be carried out for 
years between 1950 and 2050. 

Step 8. Also in “Calculation options” it is possible to set the minimum elevation of the sun 
to be used for calculations. If for example the wind farm is located in a wide flat 
terrain 3 degrees can be suitable. However if the wind farm is located in a valley 
surrounded by high mountains it is possible to set a greater elevation since the 
nearby mountains will shelter the wind farm at greater elevation of the sun – this 
will reduce the time required by WindFarmer to perform the calculations. 

Step 9. The “Calculation Time Interval” is set as default to 10 minutes.  This means that 
WindFarmer will check the position of the sun and shadows every 10 minutes 
through the year. Increasing this time will speed up the calculation but reduces the 
accuracy, and vice versa. 

Step 10. By checking the box “Correct shadow flicker for true north” it is possible to remove 
the effects of magnetic declination from the shadow flicker calculations. 

Step 11. By checking the box “Model the sun as a disc” it is possible to consider the sun for 
its real dimension rather than a point.  

Step 12. By checking the box “Consider distance between rotor and tower”, WindFarmer will 
include that small offset in its calculation.  

Step 13. The “Height above ground for shadow flicker mapping” allows you to set the height 
at which you would like to calculate the shadow flicker observations. 

Step 14. In the “Turbine Orientation”  three options are available: “Rotor plane facing 
azimuth+180” (Rotor plane always perpendicular to sun) “User defined rotor 
orientation” (User specified orientation) and “Sphere around rotor centre” (Shadow 
generated via sphere shape, not plane) 

Step 15. In “Terrain and Visibility” three options are available: “no calculation of visibility due 
to terrain” (assumption of flat terrain), “use terrain to calculate turbine visibility” (if 
the line turbine section-shadow receptor intercepts the terrain the shadow flicker 
time will not be counted) and “use terrain to calculate turbine and sun visibility” (if 
the line sun-turbine section-shadow receptor intercepts the terrain the shadow 
flicker time will not be counted). 

Step 16. The “visibility line of sight algorithm checks every (10 m is default)” is the resolution 
in the line of sight check described in step 11 (in the same way as the “Calculation 
Time Interval” indicated in the previous step is the resolution of the sun path). 
Usually 1/5th of the DTM resolution is the minimum recommended for reaching 
accurate results.  

Step 17. Click ‘Apply’ if you have made any changes, and then ‘OK’ to leave the control 
panel. 
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5.2 Running a shadow flicker calculation 
Step 18. Calculate the shadow flicker map by clicking “Calculate > Shadow Map” or clicking 

the “Shadow Flicker” box in the Display bar.  WindFarmer may produce a warning 
that it has detected changes, and asking if you would like to assess the Shadow 
Flicker – if it does, then you should click ‘Yes’. A new dialogue box will open - click 
“Options>>” to expand it to the one shown below.   

 

Step 19. In “Calculate shadow flicker every…” the resolution of the shadow flicker map will 
be set. “Distance limit options” and “Calculate shadow flicker every…” can also be 
set to supersede the inputs given in “WF Control Panel > Shadow model”. 

Step 20. Press OK. The calculation may take several minutes, or even longer, depending on 
the complexity of the site. 

Step 21. At the end of the calculation click ‘OK’ and the following window will be displayed 
(except in the demo version): 

 

 

Step 22. By clicking YES the calculation will be saved and this will increase the size of the 
WOW file. Alternatively by clicking NO the map will be displayed without retaining 
the information if the WOW file is closed without saving the latest changes. The 
map, using default settings, will appear as shown below: 
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5.3 Shadow flicker map display options 
Step 23. By clicking “Control bar > Legend tab” (bottom right corner of the screen) it is 

possible to view the range of each colour band (in hours per year) and by double 
clicking on any colour it is possible to edit the colour band and insert more ranges. 
The window below will appear to allow the user to do so 

 

Step 24. With the reference to the “Bands settings” window above by clicking “Colour” it is 
possible to change the colour of a specific band, “Delete” to eliminate the band, 
“Insert lower/below” and “Insert upper/above” to increase the number of bands 
between band delimiters. With the “Specified steps” box it is possible to either 
select the lower and upper limits (unticked) or specify the number of steps and the 
step size. In “Fixed display range” it is possible to choose which range to visualise 
in the map. “Load” and “Save” are used to store the changes (as *.ban files) and 
utilise them for other projects. 
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Step 25. Another way to edit the map, with even more options, is by clicking  > Map Data 
or alternatively “View > WF Control Panel > Map Data”.  

Step 26. In “Display mapping options for:” select “Shadow Flicker Map”. The window below 
will be displayed. 

 

 

Step 27.  In “Data display” the user can choose to display the map as contours and/or data 
grid. 

Step 28. “Bands setting” brings the user back to the steps described above. 

Step 29. “Data grid display options” give options on the display of the data grid. By unticking 
“Show extents” the user can remove the circles showing the extent of the 
calculation. 

Step 30. “Contour display options” gives the available options if the map is displayed as 
contour lines. 

Step 31. In “Display shadow map as” it is possible, by using the drop down menu, to select a 
map that shows the “hours per annum” (default) or have a more specific “minutes 
for a specified date” (below that in the window the date can be selected). 

Step 32. Press APPLY and OK to store the changes. 
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5.4 Shadow receptors 
Besides generating shadow flicker maps, the Shadow Model can also be used to assess 
shadow flicker at specific “Shadow Receptors”, where shadow flicker in a dwelling can be 
determined. The user can also produce detailed Shadow Flicker Reports specific for each 
turbine. These can be implemented for turbine shut down procedures of the wind farm when 
the wind farm is operational. 

Step 33. Turn off the shadow flicker map in the display bar. 

Step 34. Click  on the map toolbar or go to “Modes > Shadow Receptor” 

Step 35. As you see in the Control bar >Information tab” on the right of the screen two 
shadow receptors are already present on site (southwest and northeast of the 
wind farm). Fix a third receptor very close to the wind farm between Turbines 3 
and 6 by right clicking with the mouse. 

 

 

Step 36. Double click on shadow receptor 3 in the “Control bar > Information tab” while in 
Receptor mode or alternatively, if back in working mode using , right click over 
the receptor and select ‘Shadow receptor properties’. The dialog box below will be 
displayed. 
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Step 37. In the “Shadow Receptor” dialog box the user can fix the geometrical properties of 
the receptor and evaluate from individual turbines at any date of the year, or the 
worst day of the year, the minutes of shadow flicker that occur. In this case, using 
default settings, the worst day is the 31st of January. By flicking through other 
dates and clicking APPLY it is possible to evaluate the minutes in other days. 

Step 38. Note that the button APPLY has to be pressed to store any editable input before 
closing the window. 

5.5 Exporting shadow flicker reports 
Step 39. Click “File > Generate Report” to display the window below 

 

Step 40. On the list on the left click on “Shadow Flicker Data” to highlight it in blue. 

Step 41. Click “Add >>” to shift it under “Report Contents”. 

Step 42. Click “Generate Report”. 

Step 43. Save the file in word, excel or txt format. If saved as *.doc GH reporter will be 
activated to generate the file.  

Step 44. Open the Shadow Flicker report to gain familiarity with its content. Chapter 1 shows 
some of the relevant input data of the model. Chapter 2 shows a sequence of 
tables where, for each receptor, the days and the hours of shadow flicker from a 
specific turbine are indicated with high detail. Shut down strategies of the wind 
farm to avoid annoyance from shadow flicker at the receptors can be planned 
using this information. 
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5.6 WindFarmer Shadow Reporter Tool 
WindFarmer includes an extra tool to generate plots of the Shadow Flicker occurrence at 
shadow receptors. These are extremely useful for getting a visual understanding of the 
extent of the phenomenon. 

Step 45. Go to “File > Launch Shadow Reporter...” An Excel spreadsheet will be 
automatically opened. You should give permission to MS Excel software to use 
external macros if this is disabled by default. 

 

Step 46. Click on the “Import WindFarmer report”, and select the Shadow Flicker report 
previously generated in Section 5.5. This can either be in .txt format or .xls format. 
Doc format is not supported for this purpose. 

Step 47. The WF Report tab will automatically populate. This means the report has 
successfully been loaded. 

Step 48. Enter the time zone of your wind farm site. This must be the same as you used in 
WindFarmer - you can check it in “Control Panel > Shadow model > TimeZone 
from GMT”. 

Step 49. Click on the “Create Plots” button. A new worksheet will be created in the 
spreadsheet, for each shadow receptor which has registered the flickering effect. 
The plots show the start and stop times of the phenomenon per turbine; 
sunrise/sunset times are also displayed for reference. The Y axis represents the 
day of the year and the X-axis is the time within the day. 
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Step 50. A brief summary report of the results can be generated.  On the “Setup” worksheet, 
first enter the limits for acceptable shadow flicker, both as minutes/day and 
hours/year.   

Step 51. Click on “Create Summary Reports” button and have a look at the ”Summary 
project 1” worksheet that it is automatically created. If limits are exceeded, an 
orange background will show. 

receptor ID
receptor 
name

annual 
shadow 
flicker 
[hh:mm]

number of 
days with 
flicker

number of 
days for 
which the limit 
is exceeded worst day

minutes on 
worst day

turbines 
causing 
flicker turbine 1 turbine 2 turbine 3 turbine 4 turbine 5 turbine 6

1 S1 51:20 104 32 24/12/2011 70  1,  2,  4,  5,  6 6:30 7:20 24:10 9:40 3:40
2 S2 - 160 deg 7:20 41 0 22/04/2011 20  2,  3 3:40 3:40  

Step 52. Finally, you can save these plots and reports as an Excel spreadsheet (*.xls). 

 

End of the exercise. 
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6. FINANCIAL MODULE 
This is in the form of a Microsoft Excel compatible spreadsheet with the flexibility to allow the 
incorporation of existing spreadsheets as most organisations like to design their own financial 
models. See Section 7 of the User Manual for more details. 

6.1 Setting up electrical network and roads 
Step 1. Open the file “Demosite.wow” located in the demodata directory of the WindFarmer 

library. 

Step 2. Turn off the DTM and the Terrain in the “Map data” bar and “Boundaries” and 
“Boundary points” in the “Map object bar”. This is only made to make the 
workspace clearer to view as shown below 

 

Step 3. The first target is to draw a simple electrical grid and a road network which will be 
counted as a cost in the financial spread sheet.  

Step 4. Click  on the mapping toolbar or go to “Modes > Cabling” in the menu. 

Step 5. Insert a cable route between the two groups of turbines 1-2-3 and 4-5-6 by right 
clicking in the map. For the specific example make sure to draw a meter and three 
nodes.  See the User Manual and Electrical Module Tutorial for more advice on 
how to draw an electrical network. 

Step 6. Click  and add the connection turbine to node at each turbine by clicking the 
node of connection in “Control bar > Information tab”. 

Step 7. Left click on the turbine in the map holding down the control key (Ctrl). This 
operation is repeated for each cable connection turbine to node. The suggested 
cable layout obtained from these two steps is shown below 
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Step 8. Click  on the mapping toolbar or go to “Modes > Roads” to add the main road to 
the site. 

Step 9. In “Road mode” draw the main road by right clicking around the wind farm. Make 
sure that each turbine is close enough to a specific node. See the figure below as 
example. 

 

Step 10. Click  on the main toolbar or go to “View > Project Properties”. 

Step 11. Switch the window to “Tracks & Electrical”. The top of the window is shown below. 

 

 

Step 12. As an example enter “WF Road” as Rough track. For the specific example we will 
assume one track type for the entire site. 

Step 13. Press APPLY and OK to store the changes 

Step 14. Click  on the mapping toolbar 

Step 15. Double click any of the nodes under “Group ID” to open the following dialog box. 
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Step 16. This window allows you to change the properties of the track. Click “OK” once you 
are familiar with it.   

Step 17. Run the energy test for the given layout by clicking  or going to “Calculate > 
Energy/Test” in the menu. For this exercise we are not interested in the settings 
used for the energy calculation or in detailed specification of the cable network. 
Refer to the tutorial of the Electrical Module for more details on how to load 
specifications for the electrical equipment.  

 

Step 18. Close the Energy Report that will be displayed at the end of the energy test. 
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6.2 Using the Finance window 
Step 19. Click  or go to “Window > Finance Window” in the menu. 

Step 20. WindFarmer will issue a warning, because not all the details of the electrical 
network have been configured.  Click OK to close the warning.  In this example, 
only the cable cost per metre will be calculated, because of this incomplete set up. 

The default financial spreadsheet displayed is shown below. The user can decide to use it 
as it is or customise it on the basis of new information collected during the development 
process. A good knowledge of economics of the wind farm is essential in order to input the 
correct values. The main feature of this spreadsheet is that it allows the user to create an 
automatic interlink between the project as set in the “Mapping Window” and the content of 
the spreadsheet. Therefore changes of road layout, changes of turbine model or layout and 
other changes are automatically fed through as inputs to the financial model. Furthermore 
the user can optionally input the cost per MW, per WTG, per unit or a fixed cost. In this 
tutorial the aim is to produce a very simplified example of a cost sheet and demonstrate 
how to use the links. Costs are given as illustrations only.  

Note that the financial toolbar will have appeared on the screen (see arrow):      

 

Step 21. You will see at the top of the spreadsheet that the number of turbines and, if you 
scroll to the right, the net annual production are displayed. 

Step 22. Click on “Track type 1 – link label” in the “Civil Construction” table (cell B13). 

Step 23. Click  on the financial toolbar or by selecting “Insert Length of Track” from the 
insert Menu. The dialog box below will appear. 
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Step 24. Click “Type Label”, select “1 - WF Road” in the dropdown and press OK.  

Step 25. Now click on cell C13. Click  on the financial toolbar or by selecting “Insert 
Length of Track” from the insert Menu. Click  “Type Data” and select “1- WF Road” 
from the dropdown. Then click OK. The total road length, as laid out in the 
mapping window, will appear. For reference this road length is calculated 
considering the local topography. 

Step 26. Input 10 as cost per m of road (cell F13). 

Step 27. The total cost for the road is automatically calculated and displayed in H13. 

Step 28. Input 30000 as cost per turbine (cell F7). Note that the cell is linked to the number 
of turbines (cell C7) to produce a total turbine cost of 180000 in cell H7. 

Step 29. Go to “Cable trenching and laying – Total Length” in the “Site electrical 
Infrastructure” and set a cost per m of 60 (cell F19). 

Step 30. Go to cell C19 and click  on the financial toolbar or go to “Insert > Length of 
cable” in the menu. 

Step 31. Choose “Type Data” and select “All Types” to assume same cost per unit for all 
cables. If the user has input more specific names of cables in the Electrical Module 
the user has the option to associate different costs per unit at each cable type. 

Step 32. If you are using the Demo version of WindFarmer, this next step will have been 
completed for you: In the worksheet “Financial Assumptions” input the number of 
turbines in cell C5 by clicking  or selecting “Insert > Number of Turbines”, 
select “Type Data” and select the Generic Turbine. Select cell C10 and add the net 
energy yield (P50) by clicking  or selecting “Insert > Annual Energy Yield”. 
Select “Type Data” and select the Generic Turbine. Enter the turbine capacity 
(0.75 MW) in cell C6. 

Step 33. Look at the other worksheets “operational cashflow”, “debt cashflow” and “debt and 
retained earnings chart” to see the resulting financial analysis.  

End of the exercise. 

Note that the spreadsheet used in this tutorial is a template spreadsheet provided with the 
Demo CD for demonstration purposes.  

The main focus of this tutorial is to show the user how links project-financial spreadsheet work. 
It should be noted that by clicking  on top of the financial toolbar or through “File > Load 
spreadsheet” it is possible to load other ready-made financial spreadsheets and then link to the 
project. This is only available in the full version of WindFarmer. 
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